Server Maintenance
Incident Report for Self-Hosted.
Postmortem

We have successfully integrated LiteSpeed technology into our server hosting which will allow all WordPress website hosted with us to load at faster speeds.

Posted Jun 09, 2020 - 08:27 PDT

Resolved
Maintenance to integrate LiteSpeed into WordPress hosting plans
Posted Jun 09, 2020 - 07:45 PDT